Database is not responding
Incident Report for eMarketeer
Postmortem

Overview

At 15:38 on February 14, we suffered a little more than 40 minutes downtime due to a non scheduled database job on our primary database machine. This affected all parts of the system.

All system was back to normal at 16:20.

What Happened

Due to human error a database upgrade was scheduled outside a maintenance window.

Root Causes

Human error working in the database interfaces. We have implemented a two step approach for this kind of work to prevent this to happen in the future.

Resolution

The unscheduled upgrade job takes more than 5 hours to complete, and during this time stays offline. To bring the system up faster we restored the system from the backup made before the upgraded started.

Impact

_All users and all functions was affected during the incident. During the downtime there was a small window (approx 20 mins) where user could login and work in the system. Any saved work during this time is lost. This should affected very few customers.
_

Posted Feb 15, 2019 - 13:26 CET

Resolved
This incident has been resolved.
Posted Feb 14, 2019 - 16:44 CET
Monitoring
we are monitoring the current stability of the database but it can accept incoming traffic again
Posted Feb 14, 2019 - 16:40 CET
Identified
Currently the eMarketeer databse is down, We are working on to get it back up and running as soon as possible.
During this time anything that needs a connection will not work. like:
Login,
Links in emails,
Forms.
Posted Feb 14, 2019 - 15:42 CET
This incident affected: API and Campaigns.